about:home search form not submitting

Post Reply
JosephFisher
Posts: 5
Joined: Fri Nov 12, 2010 11:34 am

about:home search form not submitting

Post by JosephFisher » Thu Oct 06, 2011 12:35 pm

We've just deployed FMFF 7.0.1. I've noticed that the default about:home page (with the frontmotion firefox earth logo) google search box doesn't submit. You can type into the box, but pressing search or hitting enter does nothing. I've noticed this on multiple machines that we deployed 7.0.1 to. Not sure if this is a bug in the package, or on some remotely hosted website somewhere. Anybody else experiencing this?

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: about:home search form not submitting

Post by DraconPern » Tue Oct 11, 2011 7:26 pm

No problems here, works as expected on en-US
FrontMotion Lead Developer

AlexB
Posts: 7
Joined: Mon Oct 17, 2011 10:06 am

Re: about:home search form not submitting

Post by AlexB » Tue Oct 18, 2011 7:06 am

exactly the same issue here..

AlexB
Posts: 7
Joined: Mon Oct 17, 2011 10:06 am

Re: about:home search form not submitting

Post by AlexB » Wed Oct 19, 2011 4:45 am

seem to have found the cause, when I have 'browser.startup.homepage_override.mstone' enabled and set to 'ignore' in group policy (to stop the what's new tab) and run firefox for the first time (i.e. no profile folder in app data) then the about:home page doesn't work.

If i set 'browser.startup.homepage_override.mstone' to not configured, gpupdate on the machine, delete the firefox profile folder and run it (as first time) then the whats new tab opens but the about:home page works correctly.

I can enable/disable that policy option and get the about:home page to work or not work every time.

MadFurai
Posts: 18
Joined: Tue Oct 18, 2011 10:05 am

Re: about:home search form not submitting

Post by MadFurai » Thu Oct 20, 2011 6:51 am

YES!!! I thought it was something to do with our new proxy, but now I see others are having the exact same issue. If you set the override.mstone value to ignore, then the about:home page doesn't load the Google image and the search button doesn't work.

Also, if you allow the firstrun web page to show up by removing the ignore statement, then it takes you to a URL path that gives you a 404 page not found error. The problem seems to be that the path has /projects/ in it.

AlexB
Posts: 7
Joined: Mon Oct 17, 2011 10:06 am

Re: about:home search form not submitting

Post by AlexB » Thu Oct 20, 2011 6:56 am

A work around i've found is instead of using the mstone ignore setting just set 'startup.homepage_override_url' and 'startup.homepage_welcome_url' to 'about:home'.

That way, each upgrade/first-run will result in two tabs opening to about:home but at least about:home works and there's no 404 page problems.

MadFurai
Posts: 18
Joined: Tue Oct 18, 2011 10:05 am

Re: about:home search form not submitting

Post by MadFurai » Thu Oct 20, 2011 8:00 am

My workaround was to set the welcome URL to this:

http://www.mozilla.com/en-US/firefox/%V ... /firstrun/

and the override_url to this:

http://www.mozilla.com/en-US/firefox/%V ... /whatsnew/

This prevents the 404 error, but doesn't help if you are still wanting to use the "ignore" statement.

Post Reply