Firefox ESR 17.0.3 CE, one Group Policy setting not applied

Post Reply
Sven
Posts: 2
Joined: Fri Mar 15, 2013 9:38 am

Firefox ESR 17.0.3 CE, one Group Policy setting not applied

Post by Sven » Fri Mar 15, 2013 9:49 am

Hi Community,

I have installed Firefox 17.0.3 ESR and have added the adm files to the Group Policy Editor. I configured within GPO editor proxy settings, startup page and disabled updates. This works without problems. I also tried to disable the installation of extensions with "xpinstall.enabled" and set it to disabled. All settings are applied except for the exensions. I checked the registry under HKLM\SOFTWARE\Policies\Mozilla\lockPref and can see that all settings are applied but Firefox ignores the one with "xpinstall.enabled".

Is there any other setting I can use?

Sven
Posts: 2
Joined: Fri Mar 15, 2013 9:38 am

SOLVED: Firefox ESR 17.0.3 CE, one Group Policy setting not

Post by Sven » Sat Mar 16, 2013 4:32 pm

Hi community,

issue solved.

I added pref("xpinstall.enabled", false); to greprefs.js. With this line in place I can change the setting in the GPO to enable/disable and the value in the GPO gets the preference. Then I double checked and removed the line from greprefs,js again and I couldn't got the setting changed thourgh GPO.


Thanks anyway.

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: Firefox ESR 17.0.3 CE, one Group Policy setting not appl

Post by DraconPern » Sat Mar 16, 2013 10:19 pm

Thanks for narrowing down the issue. Let me see if there's anything I can do on my end to fix this issue in the future.
FrontMotion Lead Developer

Post Reply