Crash on some machines, others can't browse

Post Reply
fleon
Posts: 3
Joined: Mon Sep 02, 2013 5:24 pm

Crash on some machines, others can't browse

Post by fleon » Mon Sep 02, 2013 5:29 pm

Hello, i am testing the standard msi's and created an update with local update publisher with the default rules it creates.
I tested it on two machines without issues (one new installation and one installation that had a prior version) and then approved the update for all our machines in the same building.

Turns out that on most of these machines firefox crashes, on other machines the window appears but the enter key when browsing doesn't work and the window decorations don't look accurate. This is on both windows XP and Win7.

I had nothing else to do but to reject the update so other users wouldn't be affected.

I didn't see any message in the event viewer so i don't know to diagnose.

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: Crash on some machines, others can't browse

Post by DraconPern » Fri Sep 13, 2013 4:20 pm

Can you take a screen shot of the error?
FrontMotion Lead Developer

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: Crash on some machines, others can't browse

Post by DraconPern » Fri Sep 13, 2013 4:47 pm

Are you using 23.0.1? It looks I am getting these random crashes also.
FrontMotion Lead Developer

fleon
Posts: 3
Joined: Mon Sep 02, 2013 5:24 pm

Re: Crash on some machines, others can't browse

Post by fleon » Wed Sep 18, 2013 10:44 am

Sadly i don't have the screenshot at hand. It installs OK, but the tab bar appears at the top of the window, and the orange firefox button appears in the next row of the screen.

Yesterday i had a user with this error and tried to install 24.0 from the official exe on top of the damaged version and it still had the same issue. I had to uninstall it completely and also delete c:\program files\mozilla firefox before installing 24.0 to fix the problem.

I suspect the issue may happen because the user is running firefox already when the install takes place, and some files don't get updated properly

I am creating a .mst that will run a custom .vbs script to kill the firefox.exe process before updating

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: Crash on some machines, others can't browse

Post by DraconPern » Thu Sep 19, 2013 4:39 pm

I have reworked the msi slightly at http://hicap.frontmotion.com/Firefox/Be ... guage>.msi
Let me know if they work.
FrontMotion Lead Developer

fleon
Posts: 3
Joined: Mon Sep 02, 2013 5:24 pm

Re: Crash on some machines, others can't browse

Post by fleon » Fri Sep 20, 2013 9:49 am

Do you have the same changes for the new 24.0 release?

On an update to a different program i only approved it to one test group, but somehow all machines are applying it , so i will test by installing the msi manually.
It would be easier to test on 24.0 since the test machines are on 23.0.1 already

User avatar
DraconPern
Site Admin
Posts: 1218
Joined: Thu Oct 30, 2003 11:47 pm
Location: Texas
Contact:

Re: Crash on some machines, others can't browse

Post by DraconPern » Fri Sep 20, 2013 2:02 pm

I plan on making the same change for 24.0, assuming all the past functionality does still stay intact. Right now I am running into a strange issue where the right click menu for copy and paste isn't translated properly when the language extensions are applied.
FrontMotion Lead Developer

Post Reply