50.1.0 Packager install failing (AccessibleMarshal.dll again)

Post Reply
Joined:Thu Sep 03, 2015 10:20 am
50.1.0 Packager install failing (AccessibleMarshal.dll again)

Post by kevfrey » Mon Jan 30, 2017 1:48 pm

On a couple computers, I am receiving the following unrecoverable error when attempting to install the latest 50.1.0 version from my Packager account:

"CUSTOM ACTION SelfReg.U.PM.unordered.AccessibleMarshal.dll FAILED (unexpected return code). LOCATION: C:\Program Files (x86)\Mozilla Firefox\, COMMAND: "C:\Windows\SysWOW64\regsvr32.exe" /s /u"C:\Program Files (x86)\Mozilla Firefox\AccessibleMarshal.dll"

It doesn't seem to be a widespread problem, as other systems in our environment have been installed without error with the same MSI. But, I can't seem to get past it on (so far) two PCs.

Needing some guidance here, everything I have tried has resulted in the same result.

I have, in the meantime, installed the latest Firefox from Mozilla directly and it installed without issue on one of the affected PCs.
When I did the installation of the direct Mozilla Firefox, then installed the packaged 50.1.0 version over the top of that, it worked.

SO, something was corrected by the direct Mozilla build.

Joined:Mon Dec 16, 2013 3:47 am

Re: 50.1.0 Packager install failing (AccessibleMarshal.dll again)

Post by Bazinalol » Thu Mar 02, 2017 8:41 am

You must check the name of your package, it's not for all langage...

Post Reply